Project

General

Profile

Bug #5057

Sync Plans not using time specified on creation

Added by Klaas D about 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

If you create a new sync plan you can enter any time you wish but its using the current time as sync date parameter

Processing by Katello::Api::V2::SyncPlansController#create as JSON
  Parameters: {"startDate"=>"2014-04-03T13:25:42.963Z", "startTime"=>"2014-04-03T18:00:43.000Z", "interval"=>"daily", "name"=>"TestSync 20:00 Daily", "sync_date"=>"Thu Apr 03 2014 15:25:42 GMT+0200 (CEST) Thu Apr 03 2014 20:00:43 GMT+0200 (CEST)", "api_version"=>"v2", "organization_id"=>"ATIX", "sync_plan"=>{"name"=>"TestSync 20:00 Daily", "sync_date"=>"Thu Apr 03 2014 15:25:42 GMT+0200 (CEST) Thu Apr 03 2014 20:00:43 GMT+0200 (CEST)", "interval"=>"daily"}}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/views/katello/api/v2/sync_plans/show.json.rabl within katello/api/v2/layouts/resource (2.1ms)
Completed 200 OK in 55ms (Views: 3.4ms | ActiveRecord: 8.6ms)
Processing by Katello::Api::V2::SyncPlansController#show as JSON
  Parameters: {"api_version"=>"v2", "organization_id"=>"ATIX", "id"=>"6"}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/views/katello/api/v2/sync_plans/show.json.rabl within katello/api/v2/layouts/resource (3.3ms)
Completed 200 OK in 18ms (Views: 4.2ms | ActiveRecord: 2.8ms)

startDate and startTime seem to wrong, both are timestamps

in addition to that you can't seem to edit the time you set of a sync plan, but that could be related to the wrong values


Related issues

Is duplicate of Katello - Bug #5162: creating sync plan does not honor entered timeClosed2014-04-11

History

#1 Updated by Justin Sherrill about 8 years ago

  • Legacy Backlogs Release (now unused) set to 13

#2 Updated by Eric Helms almost 8 years ago

  • Is duplicate of Bug #5162: creating sync plan does not honor entered time added

#3 Updated by Eric Helms almost 8 years ago

  • Status changed from New to Duplicate
  • Triaged changed from No to Yes

#4 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#5 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF