Project

General

Profile

Bug #6396

an error removing a DHCP record (record doesn't exist) stops the delete process for a host

Added by David Swift almost 5 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
DHCP
Target version:
Difficulty:
trivial
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Trying to delete a host that does not have a DHCP record generates an error that prevents deletion of the host. The error is:

{"host":{"full_messages":["Remove DHCP Settings for our.host.com task failed with the following error: ERF12-0635 [ProxyAPI::ProxyException]: Unable to delete DHCP entry for 00:25:90:00:99:00 ([RestClient::BadRequest]: 400 Bad Request) for proxy https://our.host.com:8443/dhcp"],"errors":{"base":["Remove DHCP Settings for our.host.com task failed with the following error: ERF12-0635 [ProxyAPI::ProxyException]: Unable to delete DHCP entry for 00:25:90:00:99:00 ([RestClient::BadRequest]: 400 Bad Request) for proxy https://our.host.com:8443/dhcp"]},"id":1743}}

Associated revisions

Revision 67bfd9a0 (diff)
Added by David Swift almost 5 years ago

Fixes #6396: an error removing a DHCP record (record doesn't exist) stops the delete process for a host

History

#1 Updated by Yama Kasi almost 5 years ago

I have the same issue.

I also see this on the proxy log:

E, [2014-06-26T12:28:08.155374 #9147] ERROR -- : Removing a Proxy::DHCP Record which doesn't exist

This came out of the blue, see https://groups.google.com/forum/#!topic/foreman-users/JV0Zo6P248Y

#2 Updated by Dominic Cleal almost 5 years ago

  • Status changed from New to Ready For Testing
  • Target version set to 1.8.1

#3 Updated by Dominic Cleal almost 5 years ago

  • Project changed from Foreman to Smart Proxy
  • Category changed from Smart proxies to DHCP

#4 Updated by Yama Kasi almost 5 years ago

Tested so far but doesn't seem to solve the problem yet.

#5 Updated by David Swift almost 5 years ago

Yama,

Without further detail, I cannot say if this will fix your problem or not. The root cause of your issue may actually be #6412, which I just nailed down yesterday.

#6 Updated by Yama Kasi almost 5 years ago

Hi David,

There wasn't much extra related info indeed.

Thanks btw, this other "bug" fixed it, but I wasn't awre of that one yet... I saw a lot of new reports here tho.

Thanks!

#7 Updated by Dominic Cleal almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 18

#8 Updated by Dominic Cleal almost 5 years ago

David, do you still have the proxy.log from this incident? I'd just like to include it for the record & our troubleshooting docs.

#9 Updated by David Swift almost 5 years ago

Dominic, I do have a log, with a ton of debugging I added as a temporary measure to help me narrow this down. I am out of the office this week, but I'll attach it here when I get back to work.

#10 Updated by Dmitri Dolguikh almost 5 years ago

  • Target version changed from 1.8.1 to 1.8.0

#11 Updated by David Swift almost 5 years ago

Dominic Cleal wrote:

David, do you still have the proxy.log from this incident? I'd just like to include it for the record & our troubleshooting docs.

Dominic,

Looking at the log, there is a huge amount of proprietary networking information in there. Problem is, you cannot see the bug unless the network information is consistent.

Trying to go through and replace all the IP addresses and subnets is more than I can currently do. I'll try and sanitize the log, but it is gonna take a bit.

#12 Updated by Dominic Cleal almost 5 years ago

Don't worry, it wasn't that important. Thanks for checking David.

#13 Updated by Bryan Kearney almost 5 years ago

  • Bugzilla link set to 1117836

#14 Updated by Anonymous almost 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF