Project

General

Profile

Bug #9390

subnet without organization/location and host using the subnet in org/loc => unable to set org/loc on the subnet

Added by Ohad Levy over 7 years ago. Updated over 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1191875
Description of problem:
When you create subnet without organization/location specified and create host using the subnet with organization/location, you are unable to configure organization/location for the subnet.

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150210.0-Satellite-x86_64

How reproducible:
always

Steps to Reproduce:
1. Install Satellite (I have not created any extra organization/location
besides default ones)
2. Configure provisioning (in my case I have used libvirt)
3. Create subnet without organization/location specified # hammer -u admin -p changeme subnet create --dhcp-id 1 --dns-id 1 \
--tftp-id 1 --domain-ids 1 --name jhutar3 --network 192.168.160.0 \
--mask 255.255.255.0
4. Create host using that subnet
5. Make sure you have "Default Organization@Default Location"
6. Look into Infrastructure -> Subnets
=> you can not see the subnet, which is expected
7. Switch to "Any Context"
8. Look into Infrastructure -> Subnets
=> you can see the subnet, which is expected
9. Attempt to set organization/location in Infrastructure -> Subnets
-> <your_subnet> -> Locations or Organizations
=> default org/loc are already at right side (tooltip says
"This is used by a host") and you can not configure it in any way

Actual results:
You can not configure it in any way

Expected results:
You should probably be able to configure it, or when it seems to be configured already (see step 9), it should appear with "Default Organization@Default Location" set as well.


Related issues

Is duplicate of Foreman - Bug #9391: subnet without organization/location and host using the subnet in org/loc => unable to set org/loc on the subnetClosed2015-02-15

History

#1 Updated by Dominic Cleal over 7 years ago

  • Is duplicate of Bug #9391: subnet without organization/location and host using the subnet in org/loc => unable to set org/loc on the subnet added

#2 Updated by Dominic Cleal over 7 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF