Project

General

Profile

Bug #9391

subnet without organization/location and host using the subnet in org/loc => unable to set org/loc on the subnet

Added by Ohad Levy over 5 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Organizations and Locations
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1191875
Description of problem:
When you create subnet without organization/location specified and create host using the subnet with organization/location, you are unable to configure organization/location for the subnet.

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150210.0-Satellite-x86_64

How reproducible:
always

Steps to Reproduce:
1. Install Satellite (I have not created any extra organization/location
besides default ones)
2. Configure provisioning (in my case I have used libvirt)
3. Create subnet without organization/location specified # hammer -u admin -p changeme subnet create --dhcp-id 1 --dns-id 1 \
--tftp-id 1 --domain-ids 1 --name jhutar3 --network 192.168.160.0 \
--mask 255.255.255.0
4. Create host using that subnet
5. Make sure you have "Default Organization@Default Location"
6. Look into Infrastructure -> Subnets
=> you can not see the subnet, which is expected
7. Switch to "Any Context"
8. Look into Infrastructure -> Subnets
=> you can see the subnet, which is expected
9. Attempt to set organization/location in Infrastructure -> Subnets
-> <your_subnet> -> Locations or Organizations
=> default org/loc are already at right side (tooltip says
"This is used by a host") and you can not configure it in any way

Actual results:
You can not configure it in any way

Expected results:
You should probably be able to configure it, or when it seems to be configured already (see step 9), it should appear with "Default Organization@Default Location" set as well.


Related issues

Related to Foreman - Bug #10234: Host/NicTest test failuresClosed2015-04-22
Related to Foreman - Bug #10646: Cannot build new host when locations hav been enabled and then disabled.Closed2015-05-28
Has duplicate Foreman - Bug #9390: subnet without organization/location and host using the subnet in org/loc => unable to set org/loc on the subnetDuplicate2015-02-15

Associated revisions

Revision 8f695d94 (diff)
Added by Shimon Shtein over 5 years ago

Fixes #9391 - Added validation code to NIC, so it validates that host's location/org is compatible with the one set on NIC's subnet

Revision 0c46acd4 (diff)
Added by Shimon Shtein over 5 years ago

Fixes #9391 - Added validation code to NIC, so it validates that host's location/org is compatible with the one set on NIC's subnet

(cherry picked from commit 8f695d94a2f32fea3363cc017fc59baf6ca15b17)

History

#1 Updated by Shimon Shtein over 5 years ago

  • Assignee changed from Ohad Levy to Shimon Shtein

#2 Updated by Dominic Cleal over 5 years ago

  • Has duplicate Bug #9390: subnet without organization/location and host using the subnet in org/loc => unable to set org/loc on the subnet added

#3 Updated by Dominic Cleal over 5 years ago

  • Category set to Organizations and Locations

#4 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2173 added
  • Pull request deleted ()

#5 Updated by Dominic Cleal over 5 years ago

  • Legacy Backlogs Release (now unused) set to 50

#6 Updated by Dominic Cleal over 5 years ago

  • Related to Bug #10234: Host/NicTest test failures added

#7 Updated by Shimon Shtein over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#8 Updated by Dominic Cleal over 5 years ago

  • Related to Bug #10646: Cannot build new host when locations hav been enabled and then disabled. added

Also available in: Atom PDF