Project

General

Profile

Bug #16044

Errors in individual dashboard widgets fail entire page

Added by Daniel Lobato Garcia about 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Dashboard
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1353749
Description of problem:
when using filters for Dashboard in Satellite 6.2 an sql error occurs.

Version-Release number of selected component (if applicable):

How reproducible:

Always
Steps to Reproduce:
1.Create filters for users.
2.login as user and press dashboard.
3.

Actual results:
Oops, we're sorry but something went wrong PG::Error: ERROR: missing FROM-clause entry for table "katello_host_collections" LINE 1: ...id" IN (1) AND "hosts"."location_id" IN (2) AND (("katello_h... ^ : SELECT COUNT FROM (SELECT DISTINCT "katello_errata"."id" AS count_column FROM "katello_errata" INNER JOIN "katello_content_facet_errata" ON "katello_content_facet_errata"."erratum_id" = "katello_errata"."id" INNER JOIN "katello_content_facet_errata" "content_facet_errata_katello_errata_join" ON "content_facet_errata_katello_errata_join"."erratum_id" = "katello_errata"."id" INNER JOIN "katello_content_facets" ON "katello_content_facets"."id" = "content_facet_errata_katello_errata_join"."content_facet_id" WHERE "katello_content_facets"."host_id" IN (SELECT "hosts"."id" FROM "hosts" WHERE "hosts"."type" IN ('Host::Managed') AND "hosts"."organization_id" IN (1) AND "hosts"."location_id" IN (2) AND (("katello_host_collections"."name" ILIKE 'oss%'))) LIMIT 6) subquery_for_count

Expected results:
Seeing the dashboard.

Additional info:


Related issues

Related to Foreman - Tracker #8107: Dashboard refactoring trackerNew2014-10-26

Related to OpenSCAP - Bug #16123: After upgrade "undefined method `name' for nil:NilClass" when visiting dashboard (oscap widget)Closed2016-08-16
Related to Katello - Bug #14429: Katello - deleting version 1 and associated content views caused undefined method `name' for nil:NilClass Rejected2016-03-31
Related to Foreman - Bug #16238: dashboard widget for latests events can be exteramlly slowClosed2016-08-23
Related to Foreman - Bug #16260: Intermittent DashboardIntegrationTest failuresClosed2016-08-24
Related to Foreman - Refactor #8108: use AJAX to load Dashboard widgetsResolved2014-10-26
Related to Foreman - Bug #16358: smart proxy puppet dashboard is brokenClosed2016-08-29
Related to Foreman - Bug #16702: dashboard widgets ignore filtersClosed2016-09-27
Related to Foreman - Refactor #16723: Lazy load data for dashboard widgetsClosed2016-09-28
Related to Foreman - Bug #15287: link in graph on Smart proxy -> Puppet page have "undefined" as smart proxy nameClosed2016-06-03
Related to Foreman - Bug #16704: Searching fails on dashboardClosed2016-09-27
Related to Katello - Bug #17244: Error accessing dashboard when user has filtered access to hostsClosed2016-11-07
Has duplicate Foreman - Bug #11316: A bad widget breaks the entire dashboardDuplicate2015-08-07

Associated revisions

Revision 8685d606 (diff)
Added by Tomer Brisker almost 4 years ago

Fixes #16044 - Load dashboard widgets via ajax

This speeds up dasboard loading as widgets are loaded in the background
and do not block rendering, as well as allow the dashboard to load
correctly even if some of the widgets are broken.

History

#1 Updated by Daniel Lobato Garcia about 4 years ago

  • Target version set to 117

Cloned this to Foreman because we should handle dashboard failures from plugin gracefully (currently they break the entire page if just one widget fails)

#2 Updated by Dominic Cleal about 4 years ago

  • Subject changed from ActiveRecord::StatementInvalid in dashboard to Errors in individual dashboard widgets fail entire page
  • Category set to Dashboard
  • Priority changed from High to Normal

#3 Updated by Daniel Lobato Garcia about 4 years ago

  • Target version changed from 117 to 1.6.2

#4 Updated by Tomer Brisker about 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Tomer Brisker

#5 Updated by The Foreman Bot almost 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3762 added

#6 Updated by Tomer Brisker almost 4 years ago

#7 Updated by Tomer Brisker almost 4 years ago

  • Related to Bug #16123: After upgrade "undefined method `name' for nil:NilClass" when visiting dashboard (oscap widget) added

#8 Updated by Tomer Brisker almost 4 years ago

  • Related to Bug #14429: Katello - deleting version 1 and associated content views caused undefined method `name' for nil:NilClass added

#9 Updated by Ohad Levy almost 4 years ago

  • Related to Bug #16238: dashboard widget for latests events can be exteramlly slow added

#10 Updated by Anonymous almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#11 Updated by Dominic Cleal almost 4 years ago

  • Related to Bug #16260: Intermittent DashboardIntegrationTest failures added

#12 Updated by Dominic Cleal almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 160

#13 Updated by Tomer Brisker almost 4 years ago

#14 Updated by Tomer Brisker almost 4 years ago

  • Related to Bug #16358: smart proxy puppet dashboard is broken added

#15 Updated by Dominic Cleal almost 4 years ago

  • Related to Bug #16702: dashboard widgets ignore filters added

#16 Updated by Dominic Cleal almost 4 years ago

#17 Updated by Tomer Brisker over 3 years ago

  • Related to Bug #15287: link in graph on Smart proxy -> Puppet page have "undefined" as smart proxy name added

#18 Updated by Tomer Brisker over 3 years ago

  • Related to Bug #16704: Searching fails on dashboard added

#19 Updated by Tomer Brisker over 3 years ago

  • Related to Bug #17244: Error accessing dashboard when user has filtered access to hosts added

#20 Updated by Tomer Brisker over 3 years ago

  • Has duplicate Bug #11316: A bad widget breaks the entire dashboard added

Also available in: Atom PDF