Project

General

Profile

Feature #1616

Ability to add default class(es) to all systems

Added by Jacob McCann over 10 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
External Nodes
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

It seems to me that most people have a class or a set of classes that they like to have applied to all of their systems. I think it would be great if foreman could provide a way to have this.

For me personally I just need to have the ability to apply 1 class to all systems, but I could see having additional functionality being advantageous. What I mean is maybe adding a default class based on:

1) OS
2) Some fact value

Adding logic could make it more difficult to implement, so I would say for now just a way to assign a collection of classes to all systems would be great.

Previously to support this functionality I was defining those classes in my site.pp, but it would be better to have the ability for the ENC to be a single source if used. Currently I'm 'hacking' this functionality with the attached patch (based on 0.4).

default_class.patch default_class.patch 485 Bytes Jacob McCann, 05/11/2012 02:01 PM

History

#1 Updated by Corey Osman over 10 years ago

I would really like to see a setting in foreman for default group.

Once a user setups up a default group they can say any node not belonging to this group will be assigned automatically.

The user can opt to make every host automatically get assigned to a default group in which the user would setup the group themselves and assign puppet classes to that group.

Then when puppet uses ENC script to get the YAML code a default group would be assigned containing important first time puppet classes.

#2 Updated by Steve Traylen over 10 years ago

Duplicate of #1527.

#3 Updated by David Schmitt almost 10 years ago

Steve Traylen wrote:

Duplicate of #1527.

Doesn't look like that to me. This case is concerned with adding a hostgroup for nodes which do not have any host group set. This here is very nice if nodes pop up "unannounced" e.g. when being kickstarted from satellite, but still need a basic configuration.

#4 Updated by Ohad Levy about 8 years ago

  • Description updated (diff)
  • Status changed from New to Feedback
  • Assignee deleted (Ohad Levy)

Does the config groups solve this issue? granted you still need to assign at least one config group to your hosts, but it does not enforce you to inherit other values from hostgroup?

if the answer is no, does marking one config groups as default make sense?

#5 Updated by Anonymous over 5 years ago

  • Status changed from Feedback to Resolved

can be implemented by default host/config groups.

Also available in: Atom PDF