Project

General

Profile

Bug #2082

PXE Default File seems to be broken

Added by Jasper Poppe over 9 years ago. Updated over 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Templates
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When using the supplied 'pxe default file' in Config Templates the 'Build PXE default' functionality breaks.

I get the following error:
failed to process template: exp not empty after Safemode::Parser.process_call on s(s(:call, s(:lvar, :profile), :[], s(:lit, :hostgroup)))

I suspect it is caused by the hostgroup variables used in the 'pxe default file'. IMHO default 'examples' should not rely on hostgroups since not everybody is using hostgroups and this could confuse new users even more.


Related issues

Is duplicate of Foreman - Bug #2029: Build PXE Default fails with "exp not empty after Safemode::Parser.process_call"...Resolved2012-12-10

History

#1 Updated by Jasper Poppe over 9 years ago

Hmmz, please ignore what I typed after the IMHO, it seems this example template is longer available in Foreman than I thought. Still it seems to be broken by a recent update.

#2 Updated by Ohad Levy over 9 years ago

  • Status changed from New to Duplicate

#3 Updated by Jasper Poppe over 9 years ago

Sorry about the duplicate I was testing against RC1, my fault. Would be nice if the Debian RC packages would be updated when there is a new RC.

#4 Updated by Ohad Levy over 9 years ago

Jasper Poppe wrote:

Sorry about the duplicate I was testing against RC1, my fault. Would be nice if the Debian RC packages would be updated when there is a new RC.

Normally they are, but since its vacation time for many people, expect a few delays....

#5 Updated by Jasper Poppe over 9 years ago

Clear, if I could help with the Debian building process please let me know ;)

#6 Updated by Greg Sutcliffe over 9 years ago

Deb RC3 will be out today, I'm just testing it now. Apologies for the delay. Ordinarily a version bump would be trivial, but I have a new packaging format which will be used from rc3 onward, so it's a little more complex.

There was a blog back in November on how the Debian build process works, and how anyone can participate, you can find it at http://blog.theforeman.org/2012/11/debian-packaging-transparent-way.html

#7 Updated by Jasper Poppe over 9 years ago

Thanks a lot, also for the additional information. Nice that the Git 'hack' is not needed anymore, great work! It seems RC4 debs are picky about the installation order. I Had some '@cert_chain' errors like 'abstract-1.0.0 has an invalid nil value for @cert_chain', but solved it by first installing the foreman package before packages like foreman-console, etc.. But this is off topic for this bug report ;)

#8 Updated by Greg Sutcliffe over 9 years ago

Jasper Poppe wrote:

Thanks a lot, also for the additional information. Nice that the Git 'hack' is not needed anymore, great work! It seems RC4 debs are picky about the installation order. I Had some '@cert_chain' errors like 'abstract-1.0.0 has an invalid nil value for @cert_chain', but solved it by first installing the foreman package before packages like foreman-console, etc.. But this is off topic for this bug report ;)

Thanks for the info! I would expect apt to always install foreman before the foreman-* packages anyway, but I'll double check the dependencies when I have a chance. I saw the @cert_chain stuff too, but it seems harmless as far as I've been able to tell. Do open new bugs if you find anything wrong with them :)

#9 Updated by Jasper Poppe over 9 years ago

Thanks for the info! I would expect apt to always install foreman before the foreman-* packages anyway, but I'll double check the dependencies when I have a chance. I saw the @cert_chain stuff too, but it seems harmless as far as I've been able to tell. Do open new bugs if you find anything wrong with them :)

That's what I thought but my Puppet died hard with installing RC4 (from scratch) without specifying the order. Will keep an eye on the changes ;)

Also available in: Atom PDF