Project

General

Profile

Bug #29454

container tags don't show all lifecycle envs/cvs on details page

Added by Justin Sherrill about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Container
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

With pulp3 enabled for docker:

1) sync a docker repo (library/bash)
2) publish it in a content view
3) go to the content > container image tags page, click on a tag
4) click the lifecycle env tab
5) notice that only the 'default org view' repo is shown

It seems that the api/ui is assuming a docker tag can only exist in a single repo, which is no longer the case with pulp3


Related issues

Has duplicate Katello - Bug #28795: Identical Docker tags aren't grouped by repositoryDuplicate

Associated revisions

Revision 576259f4 (diff)
Added by Ian Ballou about 2 years ago

Fixes #29454 - container tags don't show all CVVs (#8658)

  • Fixes #29454 - container tags don't show all CVVs
  • Fixes #29454 - container tags don't show all CVVs
  • Fixes #29454 - container tags don't show all CVVs
  • Fixes #29454 - container tags don't show all CVVs

Co-authored-by: Jonathon Turel <>

History

#1 Updated by James Jeffers about 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.15.0

#2 Updated by Ian Ballou about 2 years ago

For some reason, when I publish or delete a content view version, the amount of global docker tags changes. At the moment it seems the number decreases with every publish or deletion. This might be related.
Edit: this was occurring with Pulp 2 in use, not Pulp 3.

#3 Updated by Ian Ballou about 2 years ago

The issue is happening because related_tags no longer returns other tags in different content views with Pulp 3. One tag exists across the content views.

It seems like for Pulp 3, the environment details page might need to be populated from a list of repositories belonging to one tag rather than from a list of related_tags.

The plan then will be to determine if docker is running with pulp 2 or pulp 3 from the JS. Using this data, the HTML will switch between the Pulp 2 tag-centric tag environments table and the Pulp 3 repository-centric tag environments table.

#4 Updated by James Jeffers about 2 years ago

  • Target version changed from Katello 3.15.0 to Katello 3.15.1

#5 Updated by The Foreman Bot about 2 years ago

  • Assignee set to Ian Ballou
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8658 added

#6 Updated by Jonathon Turel about 2 years ago

  • Has duplicate Bug #28795: Identical Docker tags aren't grouped by repository added

#7 Updated by The Foreman Bot about 2 years ago

  • Fixed in Releases added

#8 Updated by Anonymous about 2 years ago

  • Status changed from Ready For Testing to Closed

#9 Updated by Jonathon Turel over 1 year ago

  • Fixed in Releases Katello 3.17.0 added
  • Fixed in Releases deleted ()
  • Pull request deleted (https://github.com/Katello/katello/pull/8658)

Also available in: Atom PDF