Project

General

Profile

Bug #30493

Where are files from files repo published on remote proxy

Added by Robert-Jan Oosterloo almost 2 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I have created a repository of type "file" and have uploaded some files to it.
These files are accessible from the main Katello instance via http://mainserver/pulp/isos/organization/Library/custom/product/repo/

But I can't access these files from a remote Proxy server, using the same path. I simply get a 404.

When I look on the remote Proxy under /var/lib/content/units/iso, the files are actually there, so they have synced correctly.

This is on Katello 3.15.

pulp.yml pulp.yml 281 Bytes Robert-Jan Oosterloo, 10/25/2020 01:34 PM
pulp.conf pulp.conf 48 Bytes Robert-Jan Oosterloo, 10/25/2020 01:34 PM
pulpcore.yml pulpcore.yml 119 Bytes Robert-Jan Oosterloo, 10/25/2020 01:34 PM
pulp_content.conf pulp_content.conf 749 Bytes Robert-Jan Oosterloo, 10/25/2020 01:34 PM
pulp_deb.conf pulp_deb.conf 729 Bytes Robert-Jan Oosterloo, 10/25/2020 01:34 PM
pulp_docker.conf pulp_docker.conf 1.15 KB Robert-Jan Oosterloo, 10/25/2020 01:34 PM
pulpnode.yml pulpnode.yml 281 Bytes Robert-Jan Oosterloo, 10/25/2020 01:34 PM
pulp_nodes.conf pulp_nodes.conf 936 Bytes Robert-Jan Oosterloo, 10/25/2020 01:34 PM
pulp_puppet.conf pulp_puppet.conf 1.76 KB Robert-Jan Oosterloo, 10/25/2020 01:34 PM
pulp_rpm.conf pulp_rpm.conf 1.4 KB Robert-Jan Oosterloo, 10/25/2020 01:34 PM

History

#1 Updated by Jonathon Turel almost 2 years ago

  • Project changed from Foreman to Katello

#2 Updated by Samir Jha almost 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.16.0

#3 Updated by Ian Ballou almost 2 years ago

  • Target version changed from Katello 3.16.0 to Katello 3.16.1

#4 Updated by Ian Ballou over 1 year ago

  • Target version changed from Katello 3.16.1 to Katello 3.16.2

#5 Updated by James Jeffers over 1 year ago

Robert-Jan,

Can you list the packages installed on your proxy wrt to foreman-proxy?

For example, while attempting to reproduce this, on my proxy:

# rpm -qa | grep foreman
centos7-proxy-devel.jjeffers.example.com-foreman-proxy-client-1.0-1.noarch
foreman-release-2.3.0-0.1.develop.el7.noarch
centos7-proxy-devel.jjeffers.example.com-foreman-proxy-1.0-1.noarch
foreman-debug-2.3.0-0.4.develop.20200909005656git40c5618.el7.noarch
foreman-installer-katello-2.3.0-0.2.develop.20200909143450gitff05855.el7.noarch
foreman-proxy-2.3.0-0.3.develop.20200909175230giteb27de9.el7.noarch
rubygem-foreman_maintain-0.6.10-1.el7.noarch
foreman-installer-2.3.0-0.2.develop.20200909143450gitff05855.el7.noarch
foreman-proxy-content-3.18.0-0.2.master.el7.noarch

If possible, can you also provide the contents of /etc/httpd/conf.d/pulp*.conf and /etc/foreman-proxy/settings.d/pulp*.yml ?

#6 Updated by Robert-Jan Oosterloo over 1 year ago

James Jeffers wrote:

Robert-Jan,

Can you list the packages installed on your proxy wrt to foreman-proxy?

For example, while attempting to reproduce this, on my proxy:
[...]

If possible, can you also provide the contents of /etc/httpd/conf.d/pulp*.conf and /etc/foreman-proxy/settings.d/pulp*.yml ?

James,

These are the packages installed:

# rpm -qa | grep foreman
foreman-installer-2.0.3-1.el7.noarch
of-pp-fp-001.funix.nl-foreman-proxy-1.0-1.noarch
foreman-release-scl-7-2.el7.noarch
foreman-debug-2.0.3-1.el7.noarch
tfm-rubygem-foreman-tasks-core-0.3.4-1.fm2_0.el7.noarch
tfm-rubygem-foreman_remote_execution_core-1.3.0-1.el7.noarch
rubygem-foreman_maintain-0.6.5-1.el7.noarch
foreman-proxy-2.0.3-1.el7.noarch
foreman-proxy-content-3.15.3-1.el7.noarch
foreman-selinux-2.0.3-1.el7.noarch
foreman-installer-katello-2.0.3-1.el7.noarch
of-pp-fp-001.funix.nl-foreman-proxy-client-1.0-1.noarch
foreman-release-2.0.3-1.el7.noarch

They seem about the same.

And the contents:

# ls -l /etc/httpd/conf.d/pulp*.conf 
-rw-r--r--. 1 root root   48 Jul  2 07:39 /etc/httpd/conf.d/pulp.conf
-rw-r--r--. 1 root root  749 Jul  2 07:39 /etc/httpd/conf.d/pulp_content.conf
-rw-r--r--. 1 root root  729 Jul  2 07:39 /etc/httpd/conf.d/pulp_deb.conf
-rw-r--r--. 1 root root 1182 Jul  2 07:39 /etc/httpd/conf.d/pulp_docker.conf
-rw-r--r--. 1 root root  936 Jul  2 07:39 /etc/httpd/conf.d/pulp_nodes.conf
-rw-r--r--. 1 root root 1802 Jul  2 07:39 /etc/httpd/conf.d/pulp_puppet.conf
-rw-r--r--. 1 root root 1430 Jul  2 07:39 /etc/httpd/conf.d/pulp_rpm.conf
-rw-r--r--. 1 root root 2451 Jul  2 07:39 /etc/httpd/conf.d/pulp_streamer.conf

# ls -l /etc/foreman-proxy/settings.d/pulp*.yml
-rw-r-----. 1 root foreman-proxy 137 Sep 23 08:32 /etc/foreman-proxy/settings.d/pulpcore.yml
-rw-r-----. 1 root foreman-proxy 290 Sep 23 08:32 /etc/foreman-proxy/settings.d/pulpnode.yml
-rw-r-----. 1 root foreman-proxy 290 Sep 23 08:32 /etc/foreman-proxy/settings.d/pulp.yml

Hope that helps.

#7 Updated by James Jeffers over 1 year ago

That was helpful, but I would also like to see the file contents of the httpd conf files. Is it possible to attach those as well?

#9 Updated by James Jeffers over 1 year ago

I looked over these files... I noticed that you do not have a "/etc/httpd/conf.d/pulp_iso.conf" file.

Mine looks like:

Alias /pulp/isos /var/www/pub/https/isos

<Directory /var/www/pub/https/isos>
    WSGIAccessScript /usr/share/pulp/wsgi/repo_auth.wsgi
    SSLRequireSSL
    SSLVerifyClient require
    SSLVerifyDepth 2
    SSLOptions +StdEnvVars +ExportCertData +FakeBasicAuth
    Options FollowSymLinks Indexes
</Directory>

# --- HTTP ISOS
<Directory /var/www/pub/http/isos >
    Options FollowSymLinks Indexes
</Directory>

#10 Updated by James Jeffers over 1 year ago

I just reproduced this (lack of pulp iso configuration) using the katello 3.15 installer.

#11 Updated by James Jeffers over 1 year ago

  • Status changed from New to Duplicate
  • Found in Releases Katello 3.15.0 added

This problem seems to be a duplicate of https://projects.theforeman.org/issues/30211.

The iso plugin was not enabled by default, and so the needed httpd conf files are not deployed during installation.

#12 Updated by Chris Roberts over 1 year ago

  • Target version changed from Katello 3.16.2 to Katello Recycle Bin

Also available in: Atom PDF