Project

General

Profile

Actions

Bug #9444

closed

Firebug raises: "NetworkError: 404 Not Found" on selecting the 'Domain' from "New_Host_group --> Network" tab

Added by Bryan Kearney over 9 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1191849
Description of problem:
Firebug raises: "NetworkError: 404 Not Found" on selecting the 'Domain' from "New_Host_group --> Network" tab

--
"NetworkError: 404 Not Found - https://dhcp201-167.englab.pnq.redhat.com/hostgroups/current_parameters"
"NetworkError: 404 Not Found - https://dhcp201-167.englab.pnq.redhat.com/hostgroups/domain_selected"
--

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150210.0
Sat6.1.0 beta snap2

How reproducible:
always

Steps to Reproduce:
1. Go to "configure" --> Host Group --> New Host Group --> Network
2. select domain from dropdown
a) select the domain name from drop down (make sure domain is already created one)
b) Now select the blank line from drop down

Actual results:
production.log:

Processing by HostgroupsController#current_parameters as /*
Parameters: {"hostgroup_id"=>"null", "hostgroup_parent_id"=>"undefined"}
Rendered common/404.html.erb within layouts/application (1.2ms)
Rendered layouts/base.html.erb (1.4ms)
Completed 404 Not Found in 22ms (Views: 6.1ms | ActiveRecord: 1.9ms)
Processing by HostgroupsController#domain_selected as */

Parameters: {"domain_id"=>""}
Completed 404 Not Found in 13ms (ActiveRecord: 1.6ms)

Expected results:
no error should be raised neither in production.log nor in firebug console

Additional info:


Related issues 1 (0 open1 closed)

Related to Foreman - Bug #9461: undefined method domain_selected() when selecting Host group domain/subnetClosedTomer Brisker02/19/2015Actions
Actions

Also available in: Atom PDF