Project

General

Profile

Bug #9932

Setting 'Preallocate disk' flag for oVirt compute profile does not stick

Added by Raul Laansoo over 4 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - oVirt
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Setting 'Preallocate disk' flag for compute profile (compute resource provider is oVirt) does not stick.


Related issues

Related to Foreman - Bug #10276: PreAllocated Disk option is not being retained within Compute Profile (oVirt)Duplicate2015-04-27
Related to Foreman - Feature #5197: Preallocated disk support for oVirtClosed2014-04-14
Has duplicate Foreman - Bug #12648: Checkbox "Preallocate disk" doesn't get saved for a Compute ProfileDuplicate2015-12-01

Associated revisions

Revision 545716c4 (diff)
Added by Marek Hulán over 3 years ago

Fixes #9932 - fix preallocate attribute mapping

Revision eb012a9c (diff)
Added by Marek Hulán about 3 years ago

Fixes #9932 - fix preallocate attribute mapping

(cherry picked from commit 545716c40c34acca04113642fd934af5ae1e8032)

History

#1 Updated by Lukas Zapletal about 4 years ago

  • Tracker changed from Bug to Feature

Hello, can you elaborate? What you mean by sticking? If you want this setting to be persistent, we don't have this feature yet.

Nice workaround tho is to create Compute Profile with oVirt preconfigurated. You can define as many profiles as you want, preallocate setting will be persisted.

#2 Updated by Lukas Zapletal about 4 years ago

  • Tracker changed from Feature to Bug

Oh I see it in the subject now. This is a valid bug.

#3 Updated by Richard Davis about 4 years ago

  • Related to Bug #10276: PreAllocated Disk option is not being retained within Compute Profile (oVirt) added

#4 Updated by Matthew Pullin about 4 years ago

Working on this at the moment, have a fix in place that I need to finish testing.

Essentially the setting just isn't being passed from the compute profile DB table into the web UI and the ovirt volume view just sets the checkbox to false automatically, which means that the preallocate flag doesn't exist when you hit submit.

#5 Updated by Dominic Cleal over 3 years ago

  • Has duplicate Bug #12648: Checkbox "Preallocate disk" doesn't get saved for a Compute Profile added

#6 Updated by Bryan Kearney over 3 years ago

  • Bugzilla link set to 1286033

#7 Updated by Marek Hulán over 3 years ago

  • Related to Feature #5197: Preallocated disk support for oVirt added

#8 Updated by Marek Hulán over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Marek Hulán

#9 Updated by The Foreman Bot over 3 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3291 added

#10 Updated by Marek Hulán over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#11 Updated by Dominic Cleal over 3 years ago

  • Legacy Backlogs Release (now unused) set to 141

Also available in: Atom PDF