Project

General

Profile

Bug #22357

"Content Source" not updated in the UI

Added by Evgeni Golov over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Hosts
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

This happens on Katello 3.5, but I've also seen reports from Satellite 6.3 Beta (Katello 3.4.5).

When updating a host via the UI, you can set the "Content Source" to whichever proxy available and the next load of the edit page will show that the old proxy is still selected.

However, hammer host info and the API show the correct, new proxy:

Content Information:      
    Content View:          default-p4
    Lifecycle Environment: Library
    Content Source:        pipeline-proxy-3-5-centos7.kangae.example.com

The same happens when updating the host via hammer or the API directly.


Related issues

Has duplicate Katello - Bug #19738: WebUI LifeCycle Environment/Content View/Content Source don't always match actual valuesRejected2017-06-01

History

#1 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) set to 339

#2 Updated by Andrew Kofink over 4 years ago

I have not been able to reproduce this on master/nightly. Does this occur when only switching between two proxies, or does it happen when assigning/removing a proxy?

#3 Updated by Evgeni Golov over 4 years ago

The situation was:
  • Setup Katello + Proxy using the forklift pipeline job.
  • Attach a client to the Katello host
  • Try to move that client to the Proxy

I did not try any other combinations.

#4 Updated by Andrew Kofink over 4 years ago

By "attach a client", do you mean via subscription-manager, puppet? In testing, I used the Katello server itself (added by default as a client) on 3.5, and I am still unable to reproduce this. I'm using the centos7-katello-3-5 and centos7-foreman-proxy-3-5 forklift boxes.

#5 Updated by Andrew Kofink over 4 years ago

Also no luck reproducing this on centos7-katello-3-5 and centos7-foreman-proxy-3-5 from forklift, registering a host via subscription-manager.

#6 Updated by Justin Sherrill over 4 years ago

  • Status changed from New to Need more information

Evgeni, can you setup or point us to a reproducer?

#7 Updated by John Mitsch about 4 years ago

  • Has duplicate Bug #19738: WebUI LifeCycle Environment/Content View/Content Source don't always match actual values added

#8 Updated by Evgeni Golov about 4 years ago

heck, I can't reproduce this anymore on latest 3.5. :(

#9 Updated by Andrew Kofink about 4 years ago

  • Legacy Backlogs Release (now unused) changed from 339 to 166
  • Status changed from Need more information to Closed

If anyone sees this issue, please feel free to reopen with relevant logs.

Also available in: Atom PDF