Project

General

Profile

Bug #9480

Fix multiple NICs integration with compute profiles

Added by Tomáš Strachota almost 4 years ago. Updated 5 months ago.

Status:
Closed
Priority:
High
Category:
Network
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Setting interfaces in compute attributes was temporarily disabled since we merged multiple NICs support for hosts. It also affects direct creation of VMs.

Interfaces in compute attributes UI must be enabled again and merge with host's NICs upon compute profile selection.


Related issues

Related to Foreman - Bug #9824: Unable to show or edit VMWare Compute resourceClosed2015-03-19
Related to DigitalOcean - Bug #10242: Error in digitalocean plugin in 1.8.xClosed2015-04-22
Related to Foreman - Bug #10613: VMWare SCSI Controller Selection missing in 1.8.0Closed2015-05-26
Related to Foreman - Bug #9657: API for creating host can't merge NICs from compute profilesClosed2015-03-05
Related to Foreman - Bug #11656: Network interface dropdowns not disabled on VMware host editsClosed2015-09-02
Has duplicate Foreman - Bug #9222: Compute profiles broken in nightlyDuplicate2015-02-04
Blocks Foreman - Bug #9152: Provisioning new oVirt VM's failsResolved2015-01-28
Blocks Foreman - Bug #9320: Can't create host using VMWare compute resourceResolved2015-02-11

Associated revisions

Revision 6d05514a (diff)
Added by Tomáš Strachota almost 4 years ago

Fixes #9480 - multiple NICs integration with compute profiles

From users point of view:
- interfaces setup in compute profiles is back
- interface related compute attrs get merged into host NICs upon compute
profile selection
- NIC overview table displays details in the column "Type"
- UI for direct creation of VMs fixed
- fixed removing interfaces and volumes from compute profiles

From technical point of view:
- NIC overview table is always built by js
- templates for compute resources got more structure (split to partials
"base", "interface", "volume")
- compute resources can provide custom implementation of
'providerSpecificNICInfo' function

Revision 8c678130 (diff)
Added by Tomáš Strachota almost 4 years ago

Fixes #9480 - multiple NICs integration with compute profiles

From users point of view:
- interfaces setup in compute profiles is back
- interface related compute attrs get merged into host NICs upon compute
profile selection
- NIC overview table displays details in the column "Type"
- UI for direct creation of VMs fixed
- fixed removing interfaces and volumes from compute profiles

From technical point of view:
- NIC overview table is always built by js
- templates for compute resources got more structure (split to partials
"base", "interface", "volume")
- compute resources can provide custom implementation of
'providerSpecificNICInfo' function

(cherry picked from commit 6d05514ad02676067389f44c4ba1d3daf357884b)

History

#1 Updated by Dominic Cleal almost 4 years ago

Duplicate of #9222?

#2 Updated by The Foreman Bot almost 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2182 added
  • Pull request deleted ()

#3 Updated by Dominic Cleal almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 28

#4 Updated by Tomáš Strachota almost 4 years ago

  • Has duplicate Bug #9222: Compute profiles broken in nightly added

#5 Updated by Dominic Cleal almost 4 years ago

  • Blocks Bug #9152: Provisioning new oVirt VM's fails added

#6 Updated by Dominic Cleal almost 4 years ago

  • Blocks Bug #9320: Can't create host using VMWare compute resource added

#7 Updated by Anonymous almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#8 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #9824: Unable to show or edit VMWare Compute resource added

#9 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #10242: Error in digitalocean plugin in 1.8.x added

#10 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #10613: VMWare SCSI Controller Selection missing in 1.8.0 added

#11 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #9657: API for creating host can't merge NICs from compute profiles added

#12 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #11656: Network interface dropdowns not disabled on VMware host edits added

Also available in: Atom PDF